Last Updated:
Friday, 27 February 2009 By: Steve Warner

Home | About Us | Standards | Cisco IOS® | Cisco CCNA® | Cisco CCNP® | Cisco CCIE® | Security | VoIP | Configs | Links

Search

Example Configs

Cisco DSL

 


 

1760 + WIC-1ADSL

Building configuration...

Current configuration : 25066 bytes
!
version 12.3
no service pad
service telnet-zeroidle
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname dsl
!
!
security authentication failure rate 3 log
security passwords min-length 6
logging buffered 51200 debugging
logging console critical
enable secret 5 ENABLEPASSWORD
!
username steve secret PASSWORD
!
clock timezone GMT 0
clock summer-time BST recurring last Sun Mar 1:00 last Sun Oct 1:00
!
aaa new-model
!
!
aaa authentication attempts login 1
aaa authentication login default local
aaa authentication login userauthen local
aaa authentication enable default enable
aaa authentication ppp default if-needed local
aaa authorization exec default local if-authenticated
aaa authorization network default local
aaa authorization network groupauthor local
aaa session-id common
!
ip subnet-zero
no ip source-route
no ip gratuitous-arps
ip icmp rate-limit unreachable 1
!
!
ip dhcp excluded-address 10.44.9.1 10.44.9.200
!
ip dhcp pool INTERNET
   network 217.205.209.128 255.255.255.240
!
ip dhcp pool IP-PHONE1
   host 172.18.0.202 255.255.255.0
   client-identifier 0100.03e3.698e.e5
   option 150 ip 10.44.9.10
   default-router 172.18.0.10
   dns-server 212.135.1.36 195.40.1.36
   domain-name bdsltd.co.uk
!
ip tcp synwait-time 10
ip tcp path-mtu-discovery
ip cef
ip domain name exampointers.com
ip name-server 212.135.1.36
ip name-server 195.40.1.36
no ip bootp server
!
ip ips po max-events 100
!
class-map match-any CRITICAL
 match ip dscp af31
 match ip precedence 3
 match ip dscp af32
 match protocol ipsec
class-map match-any STANDARD
 match ip dscp af11
 match ip dscp af12
 match ip dscp af13
 match ip precedence 1
class-map match-any ADVANCED
 match ip dscp af21
 match ip dscp af22
 match ip dscp af23
 match ip precedence 2
class-map match-any VIDEO
 match ip dscp af41
 match ip precedence 4
class-map match-any VOICE
 match ip dscp ef
 match ip precedence 5
class-map match-any LBE
 match protocol ipsec
 match protocol gnutella
 match protocol smtp
!
!
policy-map CLASSIFY
 class LBE
  set dscp 6
 class VOICE
 class VIDEO
 class STANDARD
 class ADVANCED
 class CRITICAL
 class class-default
  set dscp af11
policy-map CE-IN-1
 class VOICE
 class VIDEO
 class CRITICAL
 class ADVANCED
 class STANDARD
policy-map CE-OUT-1
 class VOICE
  priority percent 40
 class VIDEO
  priority percent 16 30000
 class CRITICAL
  bandwidth percent 2
 class ADVANCED
  bandwidth percent 25
  random-detect dscp-based
  police cir percent 25
    conform-action set-dscp-transmit af21
    exceed-action set-dscp-transmit af22
    violate-action set-dscp-transmit af23
 class STANDARD
  bandwidth percent 15
  random-detect dscp-based
  police cir percent 15
    conform-action set-dscp-transmit af11
    exceed-action set-dscp-transmit af12
    violate-action set-dscp-transmit af13
 class class-default
  fair-queue
  random-detect dscp-based
  random-detect dscp 0   96    128   10
  random-detect dscp 2   70    128   10
  random-detect dscp 4   58    128   10
  random-detect dscp 6   44    128   10
!
!
!
interface Null0
 no ip unreachables
!
interface ATM0/0
 description adsl-uplink
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip route-cache flow
 load-interval 30
 snmp ifindex persist
 no atm ilmi-keepalive
 dsl operating-mode auto
 dsl enable-training-log
 dsl lom 250
 hold-queue 224 in
!
interface ATM0/0.1 point-to-point
 bandwidth 256
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 pvc DATA 0/38
  vbr-nrt 288 288 1
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
!
interface FastEthernet0/0
 description $FW_INSIDE$OUTSIDE LAN
 ip address 217.205.209.129 255.255.255.240
 ip access-group 100 in
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip accounting output-packets
 ip accounting precedence input
 ip accounting precedence output
 ip nat inside
 ip virtual-reassembly
 service-policy input CLASSIFY
 no cdp enable
 speed 100
 full-duplex
!
interface Dialer1
 description DSL
 bandwidth 256
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip accounting output-packets
 ip accounting precedence input
 ip accounting precedence output
 ip nbar protocol-discovery
 ip nat outside
 ip virtual-reassembly
 max-reserved-bandwidth 100
 service-policy input CE-IN-1
 service-policy output CE-OUT-1
 encapsulation ppp
 ip route-cache flow
 no ip mroute-cache
 load-interval 30
 dialer pool 1
 snmp ifindex persist
 no cdp enable
 ppp max-bad-auth 3
 ppp lcp predictive
 ppp lcp delay 1
 ppp authentication chap callin
 ppp chap hostname USERNAME
 ppp chap password PASSWORD
 ppp ipcp predictive
 ppp multilink
 ppp multilink multiclass
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 10.0.0.0 255.0.0.0 Null0
ip route 127.0.0.0 255.0.0.0 Null0
ip route 172.16.0.0 255.240.0.0 Null0
ip route 192.168.0.0 255.255.0.0 Null0
!
logging trap debugging
logging origin-id ip
logging facility local3
logging source-interface FastEthernet0/0.2
logging 217.205.209.132
access-list 99 permit 84.92.29.137
access-list 99 permit 212.56.68.108
access-list 99 remark ALLOW TELNET ACCESS
access-list 99 permit 217.205.209.128 0.0.0.15
access-list 99 permit 10.44.9.0 0.0.0.255
access-list 99 deny   any log
dialer-list 1 protocol ip permit
snmp-server community public RO 96
snmp-server community BigOutage RO 97
snmp-server location 51.23,0.45,0,Chum-DSL
snmp-server contact http://www.yelmuch.net
no cdp run
!
banner exec ^C
 Authorized access only!
 Disconnect IMMEDIATELY if you are not an authorized user!
^C
banner login ^C
/----------------------------------\
|                                  |
|  Cholmondley Warner Home Router  |
|      Authorised Access Only      |
|                                  |
|       Contact Steve Warner       |
|                                  |
\----------------------------------/

^C
privilege exec level 7 show configuration
privilege exec level 1 show
!
line con 0
 exec-timeout 120 0
 logging synchronous
 transport output none
 stopbits 1
line aux 0
 access-class 99 in
 no exec-banner
 no exec
 transport input telnet ssh
 transport output telnet ssh
 stopbits 1
line vty 0 4
 access-class 99 in
 logging synchronous
 transport input telnet ssh
 transport output telnet ssh
line vty 5 15
 access-class 99 in
 transport input telnet ssh
!
scheduler max-task-time 5000
scheduler allocate 4000 1000
scheduler interval 500
ntp clock-period 17179983
ntp source Dialer1
ntp master
ntp server 194.152.64.34
ntp server 194.152.64.35
ntp server 158.152.1.204
ntp server 195.40.0.250
ntp server 195.40.1.250
ntp server 194.159.253.2
time-range ACTIVE
 periodic weekend 0:00 to 9:59
 periodic Monday 0:00 to 7:29
 periodic Tuesday 0:00 to 7:29
 periodic Wednesday 0:00 to 7:29
 periodic Thursday 0:00 to 8:29
 periodic Friday 0:00 to 8:29
!
end

 

 

Valid HTML 4.01!

ExamPointers.com Top

Copyright © 2001 - 2017. All trademarks acknowledged.
Hosted by NETconf Limited